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Na czwartej z map podzielono teren według spadków. Sposób 
wyznaczenia spadków terenu na podstawie modelu DTM został opisany 
w odrębnym zadaniu (ZOB. ZADANIE 51). PoniewaŜ w tym przykładzie 
na całym terenie jest tylko jedna klasa spadków (<5 stopni), mapa ta nie 
będzie wykorzystana. 

W efekcie dysponujemy trzema oddzielnymi warstwami wektorowymi, 
które w programie MapInfo naleŜy zapisać w formacie wymiany danych 
(.mif), (ZOB. ZADANIE 64). 

Pierwszym krokiem jest zaimportowanie plików .mif do IDRISI: 

> File > Import > Software-Specific Formats > MIFIDRIS > MIF 
to Idrisi (zaznaczony) > Input MIF File (kolejno: geologA.mif, 
geologB.mif, geologC.mif, geologD.mif, geologE.mif, pola.mif, 
lasy.mif, zabudowa.mif, wody_bufor.mif) > Output Idrisi vector 
file (kolejno: geologA_vec, geologB_vec, geologC_vec, 
geologD_vec, geologE_vec, pola_vec, lasy_vec, zabudowa_vec, 
wody_bufor_vec) > Reference system (plane) > Reference units 
(meters) > OK 

Teraz naleŜy dokonać zamiany plików na format rastrowy. PoniŜsze kroki 
zostały szczegółowo omówione w zadaniu poświęconym konwersji danych 
(ZOB. ZADANIE 63): 

 

� Mapa bazowa 
przepuszczalności 
ośrodka powstanie na 
podstawie mapy 
geologicznej. 
Wydzielamy klasy 
przepuszczalności (np. 
pięć klas według 
Pazdro) i ręcznie 
klasyfikujemy według 
nich wszystkie obszary 
na mapie. 
Digitalizujemy mapę 
klas 
przepuszczalności. 
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> Data Entry > Initial > Define spatial parameters 
individually > Output image (baza) > Initial value (0) > 
Output reference information > Number of rows (1000) > Number 
of columns (1000) > Minimum X coordinate (590000) > Maximum X 
coordinate (660000) > Minimum Y coordinate (420000) > Maximum 
Y coordinate (480000) > Reference system (plane) > OK > 
Reference units (meters) > OK > OK 

> Data Entry > Initial > Define spatial parameters 
individually > Output image (kolejno: geologA_ras, 
geologB_ras, geologC_ras, geologD_ras, geologE_ras, pola_ras, 
lasy_ras, zabudowa_ras, wody_bufor_ras) > Image to copy 
parameter from (baza) > OK 

> Reformat > RASTERVECTOR > Vector to raster (zaznaczony) > 
Conversion option (polygon to raster) > Vector polygon file 
(kolejno: geologA_vec, geologB_vec, geologC_vec, geologD_vec, 
geologE_vec, pola_vec, lasy_vec, zabudowa_vec, wody_bufor_vec) 
> Image file to be updated (kolejno: geologA_ras, geologB_ras, 
geologC_ras, geologD_ras, geologE_ras, pola_ras, lasy_ras, 
zabudowa_ras, wody_bufor_ras) > OK 

Posiadamy mapy bazowe, więc moŜemy zająć się operacjami 
arytmetycznymi. Pierwszą mapą wynikową będzie mapa uŜytkowania terenu. 
Będzie ona sumą map: zalesienia, gruntów ornych i zabudowy. 

W istniejących plikach lasy_ras, zabudowa_ras i pola_ras kaŜdy 
oddzielony obszar lasu, terenu zabudowanego czy pola stanowi odrębną 
klasę. My chcemy, by wszystkie lasy (w pliku lasyR) miały wartość 1, 
wszystkie grunty orne (w pliku polaR) miały wartość 2, a wszystkie tereny 
zabudowane (w pliku zabudowaR) miały wartość 3. 

Dokonujemy reklasyfikacji (ZOB. ZADANIE 45). PoniewaŜ w naszym 
przykładzie istnieje 78 obszarów lasu i jeden obszar „nie-lasu” (wartość 0), 
wpisujemy: 

> GIS Analysis > Database Query > RECLASS  > Type of file 
to reclass (image) > Classification type (user-defined 
reclass) > Input file (lasy.rst) > Output file (lasyR) > 
Reclass parameters > w pierwszym wierszu 0,0,0 > w drugim 
wierszu 1,1,79 > OK 
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Analogicznie postępujemy z mapami gruntów ornych (34 obszary, 
docelowa wartość: 2) i zabudowy (6 obszarów, docelowa wartość: 3): 

> GIS Analysis > Database Query > RECLASS > Type of file to 
reclass (image) > Classification type (user-defined reclass) > 
Input file (pola.rst) > Output file (polaR) > Reclass 
parameters > w pierwszym wierszu 0,0,0 > w drugim wierszu 
2,1,35 > OK  

> GIS Analysis > Database Query > RECLASS > Type of file to 
reclass (image) > Classification type (user-defined reclass) > 
Input file (zabudowa.rst) > output file (zabudowaR) > Reclass 
parameters > w pierwszym wierszu 0,0,0 > w drugim wierszu 
3,1,7 > OK  

Łączymy powstałe trzy mapy w jedną, na której lasy przyjmują wartość 1, 
grunty orne wartość 2, a zabudowa wartość 3. Moduł OVERLAY, słuŜący 
do operacji na mapach, nie pozwala na sumowanie więcej niŜ dwóch map 
jednocześnie. MoŜna to zrobić w dwóch krokach albo wykorzystać moduł 
IMAGE CALCULATOR: 

 

> GIS Analysis > Mathematical Operators > OVERLAY > First 
Image (lasyR.rst) > Second Image (polaR.rst) > Output Image 
(suma_roboczy_uzytki) > Overlay Options (First + Second) > OK 

 

> GIS Analysis > Mathematical Operators > OVERLAY > First 
Image (suma_roboczy_uzytki.rst) > Second Image 
(zabudowaR.rst) > Output Image (suma_uzytki) > Overlay 

� W menu 
Mathematical 
Operators znajdują się 
trzy pozycje OVERLAY, 
SCALAR i TRANSFORM.  

� OVERLAY pozwala na 
operacje arytmetyczne 
na dwóch mapach.  
� Dodawanie 
wykorzystuje się do 
pokazywania na jednej 
mapie elementów 
występujących na 
kilku mapach (tło ma 
wartość=0, obiekty na 
kolejnych mapach 
mają 
wartości=1,2,3…).  
� MnoŜenie słuŜy do 
wyznaczenia części 
wspólnej (tlo=0, 
obiekty na kaŜdej 
mapie=1).  
� Odejmowanie map 
pozwala na wskazanie 
obszarów, które nie są 
częścią wspólną 
(tło=0, obiekty na 
kaŜdej mapie =1).  
� Inną moŜliwością 
jest przykrycie mapy 
drugiej przez obiekty 
występujące na mapie 
pierwszej (First covers 
Second except where 
zero). 
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Options (First + Second) > OK  

 

Powstała pierwsza mapa. Analogicznie postępujemy podczas tworzenia 
mapy przepuszczalności według rodzaju podłoŜa. Dokonujemy reklasyfikacji 
obszarów na pięciu mapach (od geologA_ras (otoczenie=0, obiekty=1) do 
geologE_ras (otoczenie=0, obiekty=5)) i dokonujemy ich sumowania. 
W efekcie powinna powstać mapa suma_geolog o pięciu klasach podłoŜa 
i zerowej wartości otoczenia.  

W programie IDRISI moŜna posłuŜyć się kalkulatorem map. Po 

uruchomieniu modułu IMAGE CALCULATOR  wpisujemy nazwę 
mapy wynikowej oraz nazwy map wejściowych i operatory między nimi. Jest 
to znacznie wygodniejsze rozwiązanie niŜ dodawanie do siebie kolejno 
wszystkich map. Pozwala równieŜ na bardziej zaawansowane obliczenia. 

> IMAGE CALCULATOR > Output file name (suma_geolog) > 
Expression to process (geologA + geologB + geologC + geologD + 
geologE) > Process expression 

 

� W menu SCALAR do 
wartości mapy 
źródłowej moŜliwe 
jest dodanie (Add), 
odjęcie (Subtract), 
pomnoŜenie (Multiply), 
podzielenie (Divide) i 
podniesienie do potęgi 
(Exponentiate) 
wartości wpisanej 
liczby. Na przykład 
mnoŜenie przez 10 
pozwala zmienić o 
rząd wielkości wartość 
piksela. 
� Rzadziej uŜywane 
operatory 
matematyczne, m.in. 
logarytm naturalny, 
funkcje 
trygonometryczne, 
wielkości kątowe czy 
pierwiastek 
kwadratowy znajdują 
się w menu 
TRANSFORM. 
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Ostatnim etapem tworzenia mapy warunków infiltracji jest połączenie 
map suma_uzytki i suma_geolog, tak by nowe klasy tworzyły ich 
kombinacje. Wykorzystamy moduł tabeli krzyŜowej. Wybieramy:  

> GIS Analysis > Database Query > CROSSTAB > First Image 
(suma_uzytki) > Second Image (suma_geolog) > Output File 
(cross-classification image) > Output file (uzytki_x_geolog) > 
OK 

Fakt, Ŝe obszar ulega drenaŜowi jest waŜniejszy dla infiltracji niŜ 
właściwości wynikające z budowy geologicznej i uŜytkowania terenu. 
Obszary zaznaczone jako „drenaŜ” powinny „zasłonić” obiekty na mapie 
uzytki_x_geolog. Dokonujemy reklasyfikacji mapy drenaŜu i pokrywamy nią 
mapę uzytki_x_geolog: 

> GIS Analysis > Database Query > RECLASS > Type of file to 
reclass (image) > Classification type (user-defined reclass) > 
Input file (wody_bufor_ras) > Output file (wody_buforR) > 
Reclass parameters > w pierwszym wierszu 0,0,0 > w drugim 
wierszu 25,1,90 > OK 

> GIS Analysis > Mathematical Operators > OVERLAY > First 
image (wody_buforR) > Second image (uzytki_x_geolog) > Output 
image (drenaz_uzytki_geolog) > Overlay options (First covers 
Second except where zero) > OK 

Ostatnim krokiem jest dokonanie końcowej reklasyfikacji (analogicznie 
jak wcześniej) w oparciu o kryteria warunków infiltracji. Przykładowo 
obszary leśne o bardzo dobrej przepuszczalności skał przyjmą wartość 1, 
a obszary zabudowane (gdzie dominuje spływ powierzchniowy) przyjmą 
wartość 5. Ocenę obszaru pod względem kryteriów moŜna wykonać na 
podstawie literatury hydrogeologicznej. Zapisujemy końcowy plik. 
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Zadanie 47 – Metryki krajobrazowe 

OPIS PROBLEMU 

Przeprowadzamy analizę geokompleksów, w której środowisko 
przyrodnicze jest traktowane jako system. Interesuje nas ocena zaleŜności 
między wzajemnie powiązanymi elementami układu. Chcemy się dowiedzieć, 
które obszary na istniejącej mapie geokompleksów są najbardziej 
róŜnorodne. Aby móc analizować krajobraz pod względem ilościowym, 
wykorzystamy metryki krajobrazowe. Pozwalają one zilustrować za pomocą 
algorytmów komputerowych strukturę przestrzeni. 

Zastosujemy program IDRISI, który wspiera osiem wskaźników 
zgrupowanych w module PATTERN. Wykorzystuje on do obliczeń tzw. 
analizę sąsiedztwa, w której wartość piksela na mapie wyjściowej zaleŜy od 
wartości pikseli otaczających go na mapie wejściowej. 

ROZWIĄZANIE 

W przykładzie wykorzystamy inny niŜ do tej pory format danych. 
PokaŜemy jak zaimportować mapę bitową, czyli zwykły plik graficzny 
przygotowany w programie MS Paint. Jest to symulacja mapy 
geokompleksów (zawiera takie jednostki, jak uŜytki ekologiczne, las iglasty, 
droga, łęgi, sady itp). 

W programie Paint zapisujemy mapę geokompleksów jako obraz 
wykorzystujący paletę 256 kolorów: 

> Plik > Zapisz jako… > Zapisz jako typ (mapa bitowa 256 
kolorowa) > Nazwa (krajobraz) > Zapisz 

Importujemy dane do IDRISI: 

> File > Import > Desktop publishing formats > BMPIDRIS > BMP 
to Idrisi (zaznaczony) > Input file (krajobraz) > Output file 
(krajobraz_ras) > OK 

Nie znamy numerów przypisywanych poszczególnym kolorom podczas 
importu w programie IDRISI. Program automatycznie wykorzystał całą 
dostępną paletę i zakodował wartości na mapie wykorzystując wysokie 
liczby. Dla lepszej czytelności chcemy, by było wykorzystane tylko pierwsze 
13 klas (liczb). Musimy odczytać, które klasy są uŜywane, a następnie 
reklasyfikować je w kolejności narastającej, tak by liczba klas w legendzie 
odpowiadała liczbie klas na mapie. Do określenia, które klasy występują, 
posłuŜy moduł HISTO: 

> GIS Analysis > Database Query > Histo > Input file type 
(image file) > Input file name (krajobraz_ras) > Output format 
(numeric) > Class width (1) > OK 

IDRISI 16 

TAIGA 

TRIAL 

� Pierwszym ze 
wskaźników jest ocena 
bogactwa krajobrazu 
(R). Pokazuje stosunek 
liczby klas w otoczeniu 
piksela, do całkowitej 
liczby klas na mapie. 
Podobnym 
wskaźnikiem jest CVN 
(center versus 
neighbor), pokazujący, 
ile pikseli w otoczeniu 
ma inną wartość niŜ 
bieŜący piksel. 
Pozwala to na 
porównywanie 
róŜnorodności granic. 
Przykładem nieco 
odmiennym jest 
wskaźnik fragmentacji 
(F), czyli stosunek 
liczby klas w otoczeniu 
do całkowitej 
powierzchni. Wreszcie 
istnieje grupa 
wskaźników analizy 
róŜnorodności przez 
wyznaczenie proporcji 
klas (H) albo indeksu 
dominacji (Hmax-H). 
Szczegółowe wzory 
zostały opisane w 
pomocy programu. 
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Odczytujemy, które numery (Class) mają częstości (Frequency) większe 
niŜ 0. Następnie dokonujemy reklasyfikacji. W polu Reclass parameters 
w pierwszej kolumnie wpisujemy nowe klasy, czyli kolejne liczby naturalne 
(0,1,2,3,4,5,6,…), w drugiej i trzeciej kolumnie wpisujemy jednocześnie obok 
siebie numery istniejących klas (0,1,2,3,5,6,…): 

> GIS Analysis > Database Query > RECLASS > Type of file to 
reclass (image) > Classification type (user-defined reclass) > 
Input file (krajobraz_ras) > Output file (krajobraz_reclass) > 
OK 

 

Utworzenie przykładowej metryki krajobrazowej jest juŜ proste. 
PokaŜemy to na przykładzie wskaźnika CVN: 

> GIS Analysis > Context operators > PATTERN  > Input image 
(krajobraz_reclass) > Output image (krajobraz_cvn) > Pattern 
measure (CVN) > Size of area (7x7) > OK 

Z powstałej mapy moŜemy odczytać, które miejsca są najbardziej 
róŜnorodne (sąsiadują z największą liczbą klas). Są to obszary przy drogach 
i terenach zabudowanych, czyli związane z działalnością człowieka. 

� PoniewaŜ analiza 
sąsiedztwa opiera się 
na pikselach, jeden 
piksel na mapie 
krajobrazowej 
powinien 
reprezentować 
relatywnie duŜy 
obszar. 
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Zadanie 48 – Charakterystyki 
hydrologiczne 

OPIS PROBLEMU 

Przygotowujemy raport dotyczący wybranej przez nas zlewni. Interesuje 
nas zilustrowanie jak największej liczby charakterystyk hydrologicznych. 

Jako dane źródłowe posiadamy plik cyfrowego modelu terenu (DTM) 
Podkarpacia w formacie GeoTIFF .tif. Wykorzystując odpowiednie 
oprogramowanie GIS moŜliwa jest szczegółowa analiza hydrologiczna 
obszaru. Jednym z najlepszych narzędzi dla hydrologa jest program ILWIS. 
Wykonuje on obliczenia w środowisku rastrowym. MoŜna pobrać go za 
darmo ze strony http://www.52n.org/.  

 

 

ILWIS 3.6 

FREEWARE 

� Przestrzeń robocza 
ILWISa składa się z 
kilku elementów. 
NajwaŜniejszym z nich 
jest lista modułów. 
Moduły moŜna 
wyświetlić 
alfabetycznie, 
wybierając zakładkę 
(Operation-List), albo 
uporządkowane 
tematycznie (menu 
Operations lub 
zakładka Operation-
Tree). 
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ILWIS obsługuje wiele typów plików. NajwaŜniejsze z nich to: 

 

- RASTER MAP to mapy rastrowe programu ILWIS, 
- POLYGON MAP, SEGMENT MAP i POINT MAP to kolejno mapy 

powierzchniowe, liniowe i punktowe, 
- TABLE to plik tabeli z danymi, 
- GEOREFERENCE łączy informacje o współrzędnych geograficznych 

z układem pikseli. Jest to analogiczna funkcja, jak rejestracja mapy podczas 
digitalizacji (ZOB. ZADANIE 33), 

- COORDINATE SYSTEM opisuje rodzaj odwzorowania (Projection), 
- REPRESENTATION przechowuje informacje o palecie barwnej 

i sposobie wyświetlania danych, 
- DOMAIN. Domeny są nowością w dotychczas opisanych programach 

GIS. Domena to określenie zakresu (analogiczne do dziedziny 
w matematyce) dla wartości ze zbioru danych (mapy, tabeli). Wbudowane 
w program rodzaje domen to: CLASS (lista elementów, na przykład lista 
kompleksów glebowo-rolniczych), VALUE (kaŜdy obiekt/raster na mapie 
ma przyporządkowaną wartość, przykładem jest DEM), ID (kaŜdy obiekt 
posiada unikalny, identyfikujący go numer) oraz IMAGE (wartość od 0 do 
255, wykorzystywana przy mapach barwnych i zdjęciach satelitarnych). 
Oczywiście moŜna utworzyć własną domenę (ZOB. ZADANIE 53). 

ROZWIĄZANIE 

Importujemy dane: 

> Operation-Tree > Import/Export > Import Map > Import Format 
(Tagged Image File Format .TIF) > Output Filename 
(podhale_DTM) > OK 

Pliki DTM pokazują ukształtowanie powierzchni z pewnym błędem. 
Dotyczy to m.in. lokalizacji obiektów antropogenicznych. Czasem zdarza się, 
Ŝe np. komin fabryki powoduje nagły wzrost wysokości w pojedynczym 
pikselu. W przypadku analiz hydrologicznych naleŜy zlikwidować błędne 

� Siłą ILWISa jest pole 
tekstowe pod paskami 
narzędzi. Jest to 
wiersz poleceń, gdzie 
moŜemy wpisywać 
instrukcje do 
programu. Po 
opanowaniu pracy w 
ILWISie moŜna 
przekształcać mapy 
bez korzystania z 
modułów (ZOB. 
ZADANIE 49). 

� Konwersja z pliku 
.hgt do pliku .tif 
została opisana osobno 
(ZOB. ZADANIE 64). 
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sztuczne zagłębienia bezodpływowe (o wielkości pojedynczego piksela). 
W tym celu wybieramy: 

> Operation-Tree > DEM hydroprocessing > Flow Determination > 
Remove local depressions from a DEM > Input DEM (podhale_DTM) 
> Output Raster Map (czysty_DTM) > Show > Representation 
(elevation1) > OK  

 

Określenie kierunku spływu powierzchniowego. 

W pliku DEM znajdują się informacje o wysokości nad poziomem morza 
obszaru reprezentowanego przez piksel oraz przez piksele z nim sąsiadujące. 
MoŜna zatem określić, który z otaczających pikseli jest najniŜej – czyli ma 
najniŜszą wartość (Lowest Height) albo w stosunku do którego występuje 
największy spadek (Steepest Slope): 

> Operation-Tree > DEM hydro-processing > Flow Determination > 
Flow Direction > Input DEM (czysty_DTM) > Method (steepest 
slope) > Output Raster Map (splyw) > Show > Representation 
(Flowdirection) > OK 

 

Powstała mapa, na której do kaŜdego piksela przyporządkowany został 
kierunek spływu. W oparciu o mapę kierunków spływu moŜna wyliczyć, z ilu 
sąsiadujących pikseli woda spływa do bieŜącego piksela. Pozwoli to na 
ilościowe określenie wielkości spływu: 

> Operation-Tree > DEM hydro-processing > Flow Determination > 
Flow Accumulation > Flow Direction Map (splyw) > Output Raster 
Map (akumulacja) > Show > Representation (inverse) > OK 
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Narysowanie mapy sieci rzecznej. 

W oparciu o kierunek spływu moŜna przygotować mapę sieci rzecznej 
oraz wyznaczyć dla cieków atrybuty m.in. długość, spadek, klasyfikację (wg 
Strahlera, Shreve’a, Hortona). Podajemy wartość graniczną (Stream 
Threshold nr of pixels), z ilu pikseli powinna zostać zgromadzona woda, aby 
powstał ciek: 

> Operation-Tree > DEM hydro-processing > Network and 
Catchment Extraction > Drainage Network Extraction > Flow 
Accumulation Map (akumulacja) > Stream Threshold nr of pixels 
(800) > Output Raster Map (siec) > Show > True color 
(Royalblue) > False color (white) > OK 

Aby określić rząd cieku, program wyznacza węzły (miejsca połączenia 
dwóch cieków), a następnie nadaje kaŜdemu odcinkowi numer. Dla kaŜdego 
odcinka oblicza wartości (liczba cieków dopływających, długość cieku). 
NaleŜy podać minimalną długość odcinka, według której wydziela się go 
jako odrębny ciek: 

 

> Operation-Tree > DEM hydro-processing > Network and 
Catchment Extraction > Drainage Network Ordering > Input DEM 
(czysty_DTM) > Flow Direction Map (splyw) > Drainage Network 

� NaleŜy pamiętać, Ŝe 
powstanie symulowany 
obraz sieci rzecznej na 
podstawie modelu 
wysokościowego DTM, 
według zasady, Ŝe w 
miejscach, gdzie 
maleje spadek, 
wzrasta ilość 
gromadzonej wody. 
Inne elementy 
wpływające na 
powstawanie cieków 
(jak chociaŜby 
przepuszczalność 
gruntów) nie są brane 
pod uwagę. Mapa nie 
jest w pełni toŜsama z 
rzeczywistym układem 
cieków. 
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Extraction Map (siec) > Minimum Drainage Length (200) > Output 
Raster Map (klasyfikacja) > Show > Multiple colors 
(zaznaczony) > 15 (zaznaczony) > OK 

 

JeŜeli chcemy wyróŜnić rząd cieku według klasyfikacji Strahlera lub 
Shreve’a, po wyświetleniu mapy „klasyfikacja” wybieramy: 

>> Klasyfikacja > Attribute (zaznaczony) > Strahler 
(zaznaczony) > Representation (CLRSTP12) > OK 

>> Klasyfikacja > Attribute (zaznaczony) > Shreve (zaznaczony) 
> Representation (CLRSTP12) > OK 

 

 

 

� Klasyfikacja 
Strahlera jest 
obliczana z sumy 
dopływów. JeŜeli dwa 
dopływy tego samego 
rzędu (np. 2 i 2) łączą 
się, powstaje ciek 
wyŜszego rzędu (3). 
JeŜeli łączą się cieki 
róŜnych rzędów (2 i 3), 
pozostaje wyŜszy rząd 
cieku (3). W 
klasyfikacji Shreve’a 
rząd cieku od węzła 
jest sumą rzędów 
cieków dochodzących 
(np. ciek 3 rzędu i 2 
rzędu utworzy ciek 5 
rzędu). Zatem kaŜdy 
dopływ zwiększa 
rzędowość cieku. W 
obu przypadkach 
odcinki źródłowe są 
ciekiem pierwszego 
rzędu. 

� Po zaznaczeniu opcji 
ATTRIBUTE istnieje 
moŜliwość stworzenia 
mapy cieków według 
wielu innych 
kryteriów, m.in. 
długości, spadku 
podłuŜnego, 
zróŜnicowania cieku 
czy stopnia jego 
meandrowania. 
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Wyznaczenie zlewni cząstkowych. 

Na podstawie poprzednich obliczeń istnieje moŜliwość wyznaczenia 
granic zlewni elementarnych. MoŜemy zadecydować o tym, jaka będzie 
minimalna długość cieku, dla którego zostanie wydzielona zlewnia 
cząstkowa: 

> Operation-Tree > DEM hydro-processing > Network and 
Catchment Extraction > Catchment Extraction > Drainage Network 
Ordering Map (klasyfikacja) > Flow Direction Map (splyw) > 
Output Raster Map (zlewnie) > Show > OK 

W przypadku map zlewni powstają dwie mapy: rastrowa i wektorowa. 
Mapa wektorowa moŜe zostać wyświetlona jako warstwa przy mapie 
rastrowej, gdyŜ ILWIS umoŜliwia wyświetlanie na jednej mapie tylko jednej 
warstwy rastrowej. UmoŜliwia równieŜ pokazanie granic zlewni (konturów).  

 

Zadanie 49 – Mapa potencjalnej 
lokalizacji 

OPIS PROBLEMU 

Poszukujemy miejsca do lokalizacji fabryki, które powinno spełniać 
określone załoŜenia wstępne. Inwestor wymaga, Ŝeby budynek znajdował 
się: a) na terenie do 2 stopni nachylenia, b) poza depresją, c) w odległości od 
lasu nie mniejszej niŜ 300 metrów, d) poza terenem zabudowanym, e) na 
obszarze o minimalnej powierzchni 15 ha. 

Ustalenie tych kryteriów zaleŜy oczywiście od rodzaju obiektu, który 
planujemy zlokalizować. Przykładowo huta nie moŜe leŜeć w bliskim 
sąsiedztwie osiedla mieszkaniowego, a wysypisko śmieci niedaleko ujęcia 
wody. JeŜeli wykorzystamy oprogramowanie GIS, moŜemy na podstawie 
wyników zawęzić obszar poszukiwań. 

Podobny rodzaj operacji został opisany przy określaniu warunków 
infiltracji w IDRISI (ZOB. ZADANIE 46). Jednak tam wykonywaliśmy 
operacje matematyczne (algebrę map) w oknach dialogowych. ILWIS 

� Poprzez polecenie 
Catchment merge 
ILWIS pozwala wskazać 
plik z punkt\ 
� ami 
reprezentującymi 
węzły zamykające 
zlewnię. Powstaną 
wtedy zlewnie 
cząstkowe wyznaczone 
według nich. Sposób 
tworzenia mapy 
punktowej w 
programie ILWIS został 
opisany osobno (ZOB. 
ZADANIE 44). 
� Jest to niezbędne do 
stworzenia klasyfikacji 
Hortona (> Statistical 
Parametrer Extraction 
> Horton Statistics). 

ILWIS 3.6 

FREEWARE 

FWTOOLS 

2.2.8 

FREEWARE 
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pozwala natomiast na wpisywanie komend bezpośrednio do wiersza poleceń. 
Dzięki znajomości poleceń moŜemy szybko wygenerować mapę spełniającą 
łączne warunki. 

Jako dane źródłowe wykorzystamy dwie darmowe bazy danych. Pierwsza 
zawiera mapy uŜytkowania terenu zgromadzone w projekcie CORINE 2000. 
Druga baza zawiera cyfrowy model terenu SRTM w rozdzielczości 30 x 30 
metrów (ZOB. ZADANIE 50). 

ROZWIĄZANIE 

Zadanie wykonamy w programie ILWIS. Komendy będziemy wpisywać 
w wierszu poleceń, znajdującym się u góry ekranu: 

 

Pliki .prj bazy CORINE nie są prawidłowo odczytywane przez niektóre 
przeglądarki plików. W niektórych przypadkach, aby dokonać konwersji, 
trzeba posłuŜyć się programem do konwersji odwzorowania, np. FWTools 
(http://FWTools.MapTools.org).  

Po zainstalowaniu programu FWTools umieszczamy na dysku C 
w folderze data pobrane i rozpakowane pliki. Uruchamiamy program 
FWTools Shell. Wpisujemy do linii poleceń „cd\”, aby przejść do katalogu 
głównego dysku, a następnie „cd data”, aby wejść do folderu z danymi. 
Potem dokonujemy konwersji wpisując: 

ogr2ogr -t_srs "WGS84" -s_srs plik_z_odwzorowaniem.prj C:// 
plik_mapy.shp 

W katalogu głównych na dysku C:// pojawiły się prawidłowe pliki .shp. 
Importujemy je do programu ILWIS: 

 

� Projekt CORINE 
LAND COVER 2000 
zawiera informacje o 
formach pokrycia 
terenu podzielonych 
na 44 klasy. W Polsce 
występuje 31 klas 
pokrycia terenu. 
Obszary zostały 
wydzielone na 
podstawie zdjęć 
satelitarnych 
wykonanych w 2000 
roku przez satelitę 
Landsat 7 ETM. 
Obejmują obszar 
krajów członkowskich 
Unii Europejskiej. Pliki 
.shp są dostępne na 
stronie: 
http://www.eea.euro
pa.eu/themes/landuse
/clc-download 
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> Operation-tree > Import/export > Import map > Import format 
(.shp) > (pomorze.shp) > Output format (pomorze_cor) > OK 

> Operation-tree > Import/export > Import map > Import format 
(.tif) > (pomorze_dtm.tif) > Output format (pomorze_dtm) > OK 

Przeglądarka plików >> Pomorze_cor > OK > Boundaries only 
(zaznaczony) > OK 

> File > Create > Coordinate system > Coordinate system name 
(pomorze_cor) > Coordsystem formula > Related coordsys 
(pomorze_dtm) > OK > OK 

Otwieramy mapę pomorze_cor, a następnie dodajemy warstwę 
pomorze_dtm. JeŜeli wszystko zostanie wykonane prawidłowo, kontury 
mapy uŜytkowania terenu powinny pojawić się we właściwych miejscach na 
cyfrowym modelu terenu: 

> Layers > Add layer > (pomorze_dtm) > OK > Transparent (20) > 
Representation (temperature1) > OK 

 

Obydwa pliki zostały dopasowane. Pierwszym zadaniem jest wyznaczenie 
obszarów, których spadek nie przekracza dwóch stopni. Nachylenie terenu 
zostanie wyznaczone przez uŜycie tzw. filtru liniowego: 

 

 

� Plik bazy danych 
CORINE nie zawiera 
osobno informacji o 
odwzorowaniu. JeŜeli 
je teraz zdefiniujemy, 
będziemy mogli 
wyświetlać obie mapy 
jednocześnie. 
Zakładamy, Ŝe plik z 
koordynatami DTM 
będzie podstawą dla 
pliku z koordynatami 
CORINE: 

� Filtr liniowy określa, 
o ile piksele 
sąsiadujące z 
bieŜącym mają 
większą lub niŜszą 
wartość. PoniewaŜ 
ILWIS działa w 
układzie 
współrzędnych XY, 
naleŜy osobno 
wyznaczyć róŜnice 
długości (filtr DFDX) i 
szerokości 
geograficznej (filtr 
DFDY). Polecenie 
(filter) pozwala na 
wyliczenie wielu 
innych zaleŜności 
między pikselami.  
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> Operation-tree > Image processing > Filter > Raster map 
(pomorze_dtm) > Filter type (linear) > Filter name (dfdx) > 
Output raster map (spadek_x) > Domain (value) > Precision 
(0,1) > Show > OK 

> Operation-tree > Image processing > Filter > Raster map 
(pomorze_dtm) > Filter type (linear) > Filter name (dfdy) > 
Output raster map (spadek_y) > Domain (value) > Precision 
(0,1) > Show > OK 

 

MoŜliwości wiersza poleceń zostały szczegółowo opisane w pomocy. Te 
z nich, które wykorzystujemy w ksiąŜce, są wymienione poniŜej: 

- Operatory arytmetyczne to: dodawanie (+), odejmowanie (-), 
mnoŜenie (*), dzielenie (/) i potęgowanie (^), 

- Operatory logiczne to: i (AND), lub (OR) czy negacja (NOT), 
- Operatory porównania to: równy z (=), większy (>), większy lub 

równy (>=), mniejszy (<), mniejszy lub równy (<=), róŜny (<>), 
- Funkcja warunkowa: IFF ( [warunek], [jeŜeli spełniony], [jeŜeli 

niespełniony]), 
- Sprawdzenie, czy wartość istnieje: IFNOTUNDEF([obiekt], 

[wartość, jeŜeli piksel ma juŜ wartość], [wartość, jeŜeli piksel nie ma 
wartości]), 

- Inne funkcje: średnia arytmetyczna z dwóch map (AVG), wartość 
największa (MAX), wartość najmniejsza (MIN), wielkość reprezentowana 
przez piksel w rzeczywistości (PIXSIZE), wartość maksymalna na mapie 
(MAPMAX). 

Wyliczyliśmy spadek osobno dla osi X i Y. Kolejnym krokiem jest 
połączenie tych map. Tworzymy mapę spadków w procentach. Dzielimy 
spadek całkowity przez wielkość piksela (30) i mnoŜymy przez 100. 
Wpisujemy do wiersza poleceń: 
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spadek_procent = 
(HYP(spadek_x,spadek_y)*100)/PIXSIZE(pomorze_dtm) > ENTER > 
Domain (value) > OK 

Równanie moŜna odczytać: wygeneruj mapę wynikową 
„spadek_procent”, na której kaŜdy piksel przyjmie wartość 
przeciwprostokątnej w trójkącie, którego przyprostokątne tworzą wartości 
pikseli na mapach spadek_x i spadek_y; podzielonej przez rzeczywistą 

wielkość piksela na mapie pomorze_dtm i pomnoŜonej przez 100. 
Zamieniamy spadek z radianów na stopnie: 

spadek_stopnie = RADDEG(ATAN(spadek_procent/100)) > ENTER > 
Domain (value) > Value range (0), (360) > OK 

 

Uzyskaliśmy mapę spadków. Kolejno wyznaczamy obszary, które są 
nachylone pod kątem mniejszym niŜ dwa stopnie. W tym celu wykorzystamy 
funkcję warunkową: 

spadek_2 = IFF (spadek_stopnie < 2, 1, 0) > ENTER > Domain 
(BOOL) > OK 

Równanie moŜna odczytać: jeŜeli wartość piksela na mapie 
spadek_stopnie jest mniejsza od 2, na nowej mapie spadek_2 wartość tego 

piksela niech przyjmie 1, w przeciwnym razie wartość 0. 
Drugim wymogiem jest połoŜenie szukanego obszaru powyŜej poziomu 

morza. Wpisujemy do paska poleceń warunek wyboru obszarów, których 
wysokość nad poziomem morza jest większa od zera: 

wysokosc_1 = IFF (pomorze_dtm > 0, 1, 0) > ENTER > Domain 
(BOOL) > Value range (0), (1) > OK 

Kolejne trzy załoŜenia dotyczą mapy uŜytkowania terenu. Po pierwsze 
odległość od lasu powinna wynieść co najmniej 300 metrów. Musimy 
dokonać reklasyfikacji mapy w oparciu o atrybut z tabeli. JeŜeli obszar jest 
lasem, powinien przyjąć wartość 1, w przeciwnym razie 0.  

Pierwszym z nich jest przypisanie obiektom na mapie wektorowej 
wartości z bazy danych (tabeli): 

> Operation-tree > Vector operations > Polygons > Attribute 
map of polygon map > Polygon map (pomorze_cor) > Table 

� Gdy znamy wielkość, 
jaką reprezentuje 
piksel, moŜemy ją 
wpisać do formuły 
ręcznie. 

� JeŜeli tworzymy 
mapę, gdzie piksel 
moŜe przyjąć tylko 
dwie wartości 
(TAK/NIE), wybieramy 
domenę BOOL.  
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(pomorze_cor) > Attribute (CODE_00) > Output polygon map 
(pomorze_class) > Show > Representation (CLRSTP12) > OK 

Tak otrzymaną mapę naleŜy następnie przetworzyć na format rastrowy. 
PoniewaŜ chcemy dokonać sumowania map, wybieramy ten sam układ 
georeferencji, co w pliku DTM: 

> Operation-tree > Rasterize > Polygon to raster > Polygon map 
(pomorze_class) > Output raster map (pomorze_class_ras) > 
Georeference (pomorze_dtm) > Show > OK 

 
W pliku pomorze_cor rodzaje uŜytkowania ziemi są podane w tabeli 

pomorze_cor w kolumnie CODE_00. Lasy mają przypisane wartości: 311, 
312, 313. 

 

Wybieramy z mapy obszary leśne. Wpisujemy warunek złoŜony: jeŜeli 
wartość piksela wynosi 311 lub 312 lub 312, niech ten piksel na generowanej 
mapie „las” przyjmie wartość 1, w przeciwnym razie niech przyjmie wartość 
„?”: 

las = IFF (((pomorze_class_ras = 311) OR (pomorze_class_ras = 
312) OR (pomorze_class_ras = 313)), 1, ?) > ENTER > Domain 
(BOOL) > OK 

Generujemy mapę odległości od lasów: 

> Operation-tree > Raster operations > Distance calculation > 
Source map (las) > Output raster map (las_odl) > Domain 
(distance) > Precision (0.001) > Show > OK 

� Legendę z 
wartościami klas 
moŜna równieŜ pobrać 
ze strony CORINE. 

� JeŜeli chcemy by 
wartość piksela była 
nieokreślona, 
przypisujemy mu 
wartość „znak 
zapytania”.  
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Na mapie odległości, jak sama nazwa wskazuje, wartość piksela oznacza 
odległość od najbliŜszego istniejącego obiektu na mapie wejściowej. Z tego 
względu na mapie wejściowej, jedynie gdy w danym miejscu jest obiekt – 
piksel powinien mieć jakąkolwiek wartość. Gdy w danym miejscu nie ma 
obiektu, od którego liczy się odległość – piksel jest nieokreślony (?). 

Na powstałej mapie pozostawiamy wartości większe niŜ 300: 

odl_300 = IFF (las_odl > 300, 1, 0) > ENTER > Domain (BOOL) > 
OK 

Oceniamy, czy ILWIS prawidłowo ustalił jednostkę odległości. NaleŜy 
uwaŜać w sytuacji, gdy mapa bazowa nie ma układu współrzędnych 
kilometrowych, ale układ współrzędnych geograficznych (w stopniach). 

Wyznaczamy obszary inne niŜ tereny wykorzystywane w celach 
mieszkaniowych lub usługowych (w bazie CORINE są to klasy: 111, 112, 
121, 122, 123 i 124): 

nie_zabudowa = IFF ((pomorze_class_ras = 111) OR 
(pomorze_class_ras = 112) OR (pomorze_class_ras = 121) OR 
(pomorze_class_ras = 122) OR (pomorze_class_ras = 123) OR 
(pomorze_class_ras = 124), 0, 1) > ENTER > Domain (BOOL) > OK 

Sumujemy powstałe mapy spełniające kryteria spadku, wysokości, 
odległości od lasu i braku zabudowy: 

suma = odl_300 AND nie_zabudowa AND spadek_2 AND wysokosc_1 > 
ENTER > Domain (BOOL) > OK 

Ostatnim elementem jest wybranie obszarów na finalnej mapie 
o powierzchni powyŜej 15 ha. Dokonujemy grupowania sąsiadujących ze 
sobą pikseli w obszary: 

> Operation-tree > Raster operations > Area numbering > Raster 
map (suma) > Connect (8) > Output raster map (obszary_suma) > 
Show > OK 
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Podczas wykonywania operacji Area numbering nie tylko dokonaliśmy 
klasyfikacji obszarów, ale wygenerowaliśmy tabelę z powierzchnią kaŜdego 
z nich. 

Przypisujemy pikselom wartość powierzchni z tabeli. Liczba pikseli 
znajduje się w kolumnie „npix”: 

> Operation-tree > Raster operations > Attribute map of raster 
map > Raster map (obszary_suma) > Table (obszary_suma) > 
Attribute (npix) > Output raster map (powierzchnia) > Domain 
(count) > Show > OK 

 

Wybieramy powierzchnię powyŜej 15 ha, czyli 150000 m2: 

wynik = IFF (powierzchnia > 150000, 1, ?) > ENTER > Domain 
(BOOL) > Show > OK 

Znalezione potencjalne miejsca do lokalizacji fabryki wyświetlamy na 
podkładzie DTM. 

� W opcji Connect 
decydujemy czy za ten 
sam obszar uznajemy, 
jeŜeli piksele stykają 
się jedynie bokami (4) 
czy równieŜ 
naroŜnikami (8). 
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Zadanie 50 – Mapa izohips 

OPIS PROBLEMU 

Chcemy poprawić czytelność tworzonej mapy dodając jako podkład 
izohipsy, czyli linie łączące punkty o tej samej wysokości. Dzięki temu 
moŜliwe będzie odczytanie na mapie połoŜenia obiektów nad poziomem 
morza. Jednak nie chcemy wykonywać Ŝmudnego procesu digitalizacji 
izohips na podstawie mapy topograficznej (ZOB. ZADANIE 28). Z kolei 
izolinie generowane przez programy wykorzystujące interpolację (ZOB. 
ZADANIE 55) są obarczone szeregiem błędów i nie przedstawiają 
prawidłowo badanego terenu. 

Z pomocą przychodzą nam pliki DTM. Są to pliki rastrowe, w których 
kaŜdemu pikselowi przypisana jest wysokość nad poziomem morza. MoŜna 
z nich łatwo wyodrębnić piksele o „okrągłej” wartości, a w pozostałych 
miejscach dokonać interpolacji. W ten sposób przygotujemy mapę izohips. 

Do wykonania podkładu wykorzystamy plik przedstawiający Sudety 
i Kotlinę Kłodzką (sudety.xyz). Jako dane źródłowe wykorzystamy pliki 
DTM, zgromadzone w projekcie SRTM. 

ROZWIĄZANIE 

PoniewaŜ IDRISI nie pozwala na import plików .hgt, w których zapisane 
są dane projektu SRTM, naleŜy wykorzystać program do konwersji. 
Przykładami programów, które pozwalają odczytać pliki .hgt są m.in.: 
płatny Global Mapper lub bezpłatny MicroDEM. Za pomocą tych 
programów moŜna otworzyć pliki .hgt i zapisać np. jako tekstowy plik 
dtm.xyz (ZOB. ZADANIE 64).  

IDRISI 16 

TAIGA 

TRIAL 

� W 2000 roku w ciągu 
11 dni misji promu 
kosmicznego 
Endeavour wykonano 
cyfrowy model terenu 
dla praktycznie całej 
kuli ziemskiej. 
Rozdzielczość, czyli 
wielkość pojedynczego 
piksela w systemie 
SRTM 30 przedstawia 
obszar 30 x 30 
metrów. Zbiór 
darmowych plików dla 
Europy znajduje się 
m.in. na stronie: 
http://netgis.geo.uw.
edu.pl/srtm/Europe/ 
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Importujemy pliki .xyz do programu IDRISI: 

> File > Import > General Conversion Tools > XYZIDRIS > XYZ to 
Idrisi (zaznaczony) 

Podglądamy plik XYZ np. w programie Notatnik. Orientujemy się czy 
kolejne wartości w pliku oddzielone są przecinkiem (comma), spacją (space) 
czy średnikiem (semicolon). W naszym przykładzie jest to przecinek: 

> Comma delimited (zaznaczony) > Input XYZ ASCII File 
(sudety.xyz) > OK > Output Idrisi vector file (sudety_vec) > 
Reference system (plane) > OK > OK 

 

Plik DTM został zamieniony na plik wektorowy w którym punkty 
reprezentują kolejne piksele. Dokonujemy konwersji do formatu rastrowego. 
Wykorzystujemy wskazówki z osobnego zadania (ZOB. ZADANIE 63): 

> Composer > Georeferencing > spisujemy wartości skrajne > OK 

> Data Entry > Initial > Define spatial parameters 
individually (zaznaczony) > Output image (sudety_ras) > 
Initial value (0) > Output reference information > Number of 
columns (306) > Number of rows (168) > Minimum X coordinate 
(15.98) > Maximum X coordinate (17.00) > Minimum Y coordinate 
(50.10) > Maximum Y coordinate (50.66) > Reference system 
(plane) > Reference units (meters) > OK > OK 

> Reformat > RASTERVECTOR > Vector to raster (zaznaczony) > 
Conversion option > Point to raster (zaznaczony) > Vector 
point file (sudety_vec) > Image file to be updated 
(sudety_ras) > OK > Yes 

Liczby w plikach z danymi mogą być przechowywane w róŜnych 
formatach: jako liczba całkowita, dziesiętna, rzeczywista, binarnie, 
ósemkowo (jako bajt). Niektórych operacji nie da się wykonać we wszystkich 
formatach. JeŜeli program wyświetla komunikat, Ŝe nie potrafi 
automatycznie dokończyć operacji konwersji, naleŜy zmienić format 
poleceniem CONVERT: 

> Reformat > Convert > File type (Vector) > Input file name 
(sudety_vec) > OK > Output file name (sudetyC) > Output data 
file (integer) > Output file type (binary) > OK 

� Efektem końcowym 
będzie mapa 
konturowa, 
zawierająca linie o 
ustalonym przez nas 
interwale (np.: co 10 
metrów). NaleŜy 
pamiętać, Ŝe ogromne 
znaczenie ma 
rozdzielczość pliku 
DTM, wielkość obszaru 
oraz rzeźba terenu. 
Tworzenie mapy 
izohips na podstawie 
DTM o rozdzielczości 
1km x 1km dla 100 km2 
nizin raczej nie 
pozwoli na sensowne 
wyniki.  
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Samo wykonanie mapy hipsometrycznej (izohips) jest juŜ prostą 
czynnością. Pozostaje nam określenie, co ile metrów będzie przebiegać cięcie 
(wybieramy wartość 50) oraz czy chcemy dokonać interpolacji:  

 

> GIS Analysis > Surface analysis > Feature extraction > 
Contour > Input raster image (sudety_ras) > Output vector file 
(sudety_contour) > Contour interval (50) > Generalize contour 
data (zaznaczony) > OK 

We właściwościach warstwy ustawiamy 6 klas i wybieramy paletę 
kolorystyczną LineSldBipolarYGO. 

 

Mimo, Ŝe skorzystaliśmy z pliku DTM, powstały plik jest plikiem 
wektorowym. Oznacza to, Ŝe kaŜda z izolinii jest obiektem (linią). 
Przechowywanie informacji w formie wektorowej pozwala m.in. na 
nałoŜenie na siebie kilku warstw czy eksport do formatu .shp. 
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Zadanie 51 – Mapa przydatności 
rolniczej 

OPIS PROBLEMU 

Chcemy określić przydatność rolniczą gruntów w Polsce. W tym celu 
dokonamy analizę ukształtowania powierzchni na podstawie pliku DTM. 
Wykonamy dwie operacje. Pierwszą z nich jest wyznaczenie terenów 
o określonym spadku, a drugą wyznaczenie terenów o określonej ekspozycji.  

Spadek wskazuje, jaka jest intensywność procesów stokowych, natomiast 
ekspozycja określa usłonecznienie. Mapy ilustrujące te dwa elementy są 
wykorzystywane m.in. w topoklimatologii, geomorfologii czy hydrologii. 

Celem zadania jest wyznaczenie obszarów o optymalnych warunkach 
ukształtowania powierzchni do uprawy wybranego gatunku roślin w Polsce. 
Zakładamy, Ŝe takie warunki charakteryzują się następującymi parametrami: 
spadek terenu nie moŜe przekraczać 5 stopni, tereny powinny być dobrze 
usłonecznione, o ekspozycji południowej lub zachodniej. Posiadamy plik 
DTM analizowanego obszaru (polska.rst). 

ROZWIĄZANIE 

Pierwszym krokiem jest stworzenie mapy spadków: 

 

> GIS Analysis > Surface analysis > Topographic variables > 
SLOPE > Calculate (slope) > Input Elevation model (polska.rst) 
> OK > Output slope image (spadki) > Calculate slope in 
(degrees) > Conversion from unspecified to m (1) > OK 

Na powstałej mapie wartość piksela określa wielkość spadku. 
Dokonujemy klasyfikacji i przypisujemy wartość 1, jeŜeli wartość piksela jest 
mniejsza od pięciu stopni. W przeciwnym razie przypisujemy wartość 0. 
W ten sposób zaznaczone zostały obszary o spadku do pięciu stopni: 

> GIS Analysis > Database query > RECLASS > Input file 
(spadki) > OK > Output file (spadki_5) > Reclass parameters > 
w pierwszym wierszu: 1,1,5, w drugim wierszu 0,5,90, w trzecim 
wierszu 0,0,0 > OK 

IDRISI 16 

TAIGA 

TRIAL 

� To czy obszar jest 
przydatny pod 
określoną uprawę w 
znacznie większej 
mierze zaleŜy od typu 
gleby czy warunków 
wilgotnościowych. 
Dlatego aby wyznaczyć 
faktyczne potencjalne 
obszary upraw, 
naleŜałoby zebrać 
większą ilość 
informacji o obszarze i 
dokonać sumowania 
map (ZOB. ZADANIE 
46). 
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Drugim etapem jest przygotowanie mapy ekspozycji: 

> GIS Analysis > Surface analysis > Topographic variables > 
Aspect > Calculate (aspect) > Input Elevation model 
(polska.rst) > OK > Output slope image (ekspozycja) > 
Conversion from unspecified to m (0) > OK 

Na mapie wynikowej (ekspozycja) wartości od 0 do 360 określają 
kierunek świata, w którego stronę jest nachylony obszar reprezentowany 
przez piksel. Wybieramy obszary południowe i zachodnie (od 135 do 315 
stopni). Przypisujemy im wartość 1, reszcie przypisujemy wartość 0: 

> GIS Analysis > Database Query > RECLASS > Input File 
(ekspozycja) > OK > Output file (ekspozycja_SW) > Reclass 
parameters > w pierwszym wierszu: 0,0,135, w drugim wierszu 
1,135,315, w trzecim wierszu 0,315,361 > OK 

 

Na koniec wyznaczamy część wspólną: 

> GIS Analysis > Database Query > OVERLAY > First image 
(spadki_5) > OK > Second image (ekspozycja_SW) > OK > Output 
image (optimum) > Overlay options (first * second) > OK 

� Trzeba pamiętać, Ŝe 
wartość 0 wyznacza 
dokładnie kierunek 
północny, 90 
wschodni, 180 
południowy i 270 
zachodni. Dlatego 
wydzielając cztery 
strony świata, 
kierunek wschodni 
wyznaczają obszary od 
45 do 135 stopni, 
kierunek południowy 
od 135 do 225 stopni, 
kierunek zachodni od 
225 do 315 stopni. 
Natomiast na kierunek 
północny składają się 
wartości od 0 do 45 
oraz od 315 do 360.  
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Zadanie 52 – Mapa spadków i 
ekspozycji 

OPIS PROBLEMU 

Zlecono nam przygotowanie mapy spadków i ekspozycji do celów 
komercyjnych, jednak nie dysponujemy płatnym programem IDRISI (ZOB. 
ZADANIE 51). W tym zadaniu zostanie pokazane, jak wykonać taką mapę 
za pomocą darmowego oprogramowania SAGA. Posiadamy plik DTM 
obszaru Roztocza Zachodniego w formacie geoTIFF (.tif). 

SAGA obsługuje przede wszystkim pliki rastrowe, potrafi jednak 
pracować w środowisku wektorowym. Budowa programu jest modułowa 
(składa się on z niezaleŜnych podprogramów).  

 

SAGA 2.0.4 

FREEWARE 

� Po uruchomieniu 
programu SAGA 
widzimy domyślny 
układ okien programu. 
W górnej części 
znajduje się menu. 
Polecenie (File) 
pozwala załadować 
pliki z danymi, 
Operacje znajdują się 
w menu (Modules). 
NiezaleŜnie od tego, 
lista modułów 
wyświetlana jest w 
formie drzewa po 
lewej stronie. 
Pozostałe zakładki po 
lewej stronie 
pozwalają na 
wyświetlenie plików 
załadowanych do 
programu oraz 
powstałych map. Po 
prawej stronie 
znajduje się okno 
właściwości. 
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ROZWIĄZANIE 

Na początku importujemy plik DTM: 

> Module libraries > Import/Export GDAL > GDAL import raster > 
File path (roztocze.tif) > Okay 

Na pasku narzędzi pojawiły się ikony. Dwie najwaŜniejsze to ZOOM 
(po kliknięciu lewym przyciskiem myszy następuje przybliŜenie, prawym 
oddalenie) oraz PAN (przesunięcie). 

Aby wyznaczyć spadek terenu, musimy najpierw przekształcić plik 
rastrowy DTM na plik GRID: 

> Module libraries > Terrain analysis – Morphometry > Real 
area calculation 

W programie SAGA parametry w oknach dialogowych ustawia się z list 
rozwijanych. Pozycje na listach są dostępne w zaleŜności od rodzaju pliku. 
Innymi słowy przy tworzeniu mapy spadków na liście wyboru pojawią się 
tylko pliki DTM.  

Generujemy model terenu w siatce GRID: 

> Grid system (system mapy wejściowej) > Elevation 
(roztocze_dem.tif) > Real area grid (create) > Okay 

W zakładce DATA pojawił się nowy plik o nazwie funkcji, za pomocą 
której został wygenerowany. Aby został wyświetlony, klikamy go 
dwukrotnie. Pojawi się wtedy w zakładce widocznych map (MAPS). Na 
podstawie tego pliku wygenerujemy mapę spadków (Slope) i mapę 
ekspozycji (Aspect): 

> Modules > Terrain analysis – Morphometry > Local morphometry 

> Grid system (system mapy wejściowej) > Elevation (Real area 
grid) > Slope (create) > Aspect (create) > Method (Fit2) > 
Okay 

 

� SAGA ma znacznie 
lepsze wsparcie 
formatów od ILWISa. 
Pozwala odczytać pliki 
.dxf (moduł Import 
DXF), pliki .asc z 
ArcInfo, pliki Surfera 
.grd, czy nawet 
bezpośrednio format 
.hgt projektu SRTM30. 
Do importu plików 
rastrowych 
wykorzystuje 
bibliotekę GDAL. MoŜe 
importować obrazy 
rastrowe (.bmp, .jpg) i 
pliki wektorowe (.bna, 
.xyz). Pliki.shp otwiera 
bezpośrednio z menu 
(> File > Shapes > Load 
shapes). 

� Mapy wejściowe 
zaznaczone są 
strzałkami (>>), a 
wyjściowe (<<). 
� Zazwyczaj moŜliwe 
są trzy opcje w listach 
wyboru: brak wyboru 
opcji [not set], 
wybranie/zastąpienie 
istniejącej mapy 
[nazwa mapy], 
wygenerowanie nowej 
mapy [create]. 
� Program pozwala na 
wybór jednego z kilku 
algorytmów obliczania 
spadku terenu. Wybór 
odpowiedniego został 
opisany w pomocy 
programu. 
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Powstały dwie nowe mapy. Mapa spadków przyjmuje wartości od 0 do 90 
stopni, a mapa ekspozycji od 0 do 360 stopni. Kierunek północny określa 
wartość 0 stopni (ZOB. ZADANIE 51).  

Wyświetlamy mapy: 

> Maps >> na mapie ekspozycji > Okay 

 

Po prawej stronie znajdują się ustawienia mapy. MoŜemy zmienić paletę 
kolorystyczną mapy. Po zaznaczeniu mapy ekspozycji wybieramy: 

> Settings > Options > Display: Color classification > Type 
(Graduated colors) > Graduated color > Colors > … > Presets > 
Green-grey-blue > OK > Okay 

PoniewaŜ nowe pliki w programie SAGA tworzone są w pamięci 
tymczasowej, przy zamykaniu pojawi się okno z wyborem plików do 
zapisania: 

> Slope > Save (zaznaczony) > File (spadek) > Aspect > Save 
(zaznaczony) > File (ekspozycja) > Okay 

Mapy zostały przygotowane. 

  

� W oknie palety 
barwnej moŜemy 
komponować 
nasycenie trzech 
kolorów składowych: 
czerwonego, zielonego 
i niebieskiego (RGB). 
MoŜemy podać liczbę 
przedziałów (count). 
MoŜemy teŜ skorzystać 
z gotowych palet 
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Zadanie 53 – Mapa tarcia 

OPIS PROBLEMU 

Otrzymaliśmy zlecenie wytyczenia potencjalnych wariantów trasy nowej 
autostrady w województwie zachodniopomorskim. Chcemy zarówno 
wytyczyć najkrótszą drogę jak i określić, które obszary są najbardziej 
korzystne do budowy.  

Jednym z przykładów wykorzystania programów GIS jest taka 
optymalizacja transportu. Algorytmy stosowane w programach GIS 
wykorzystuje się między innymi do wytyczenia trasy planowanej drogi, 
obliczenia (przez urządzenia nawigacji satelitarnej) najkrótszej drogi albo 
wyznaczenia najlepszej drogi z uwzględnieniem punktów pośrednich, na 
przykład miejsc, które chcemy odwiedzić. 

To czy droga powinna być przeprowadzona przez obszar, w duŜym 
stopniu zaleŜy od uŜytkowania terenu. Przykładowym dobrym załoŜeniem 
jest, jeŜeli autostrada przebiega przez pola lub uŜytki ekologiczne, mniej 
poŜądany jest wariant wycinki lasu, natomiast wytyczenie jej przez bagno 
będzie niemoŜliwe. Dlatego, aby wyznaczyć najkrótszą trasę o optymalnych 
warunkach, najwaŜniejsze jest stworzenie mapy przydatności obszaru do 
budowy autostrady. 

Taki rodzaj mapy nazywamy mapą tarcia lub mapą kosztów 
jednostkowych. Wydzielamy obszary uŜytkowania terenu. Następnie do 
kaŜdego typu obszaru przyznajemy współczynnik „tarcia”, czyli oporu 
w stosunku do planowanej inwestycji. UŜytek ekologiczny jest poŜądanym 
obszarem, zatem „tarcie” dla budowy trasy jest małe (np. 1). W przypadku 
lasu wartość ta jest większa (np. 10), co oznacza, Ŝe wytyczenie trasy przez 
las jest 10 razy mniej korzystne, niŜ przez uŜytki. Wartość ujemna zwykle 
oznacza, Ŝe przez dany teren nie moŜe przebiegać trasa. 

Jako mapę wejściową wykorzystamy mapę uŜytkowania (okolice 
Szczecina) z bazy danych CORINE 2000 (szczecin_cor.shp). Import danych 
z bazy CORINE moŜe sprawiać problem. Zostało to wyjaśnione osobno 
(ZOB. ZADANIE 49).  

ROZWIĄZANIE 

Importujemy wynikową mapę uŜytkowania terenu do programu ILWIS: 

> Operation-tree > Import/Export > Import map > Import format 
(.shp shape file) > (szczecin_cor) > Output filename 
(szczecin_cor) > OK 

Tworzymy dwie punktowe mapy wektorowe. Na pierwszej znajdować się 
będzie punkt początkowy planowanej drogi, na drugiej punkt końcowy: 

> przeglądarka plików >> (szczecin_cor) > OK > Boundaries 
only (zaznaczony) > OK 

> File > Create > Point map > Map name (start) 

ILWIS 3.6 

FREEWARE 

� Zamiast mapy 
uŜytkowania ziemi 
moŜemy uŜyć jako 
podkładu dowolną 
mapę, na której 
moŜna łatwo 
zlokalizować w 
przestrzeni punkt 
początkowy i końcowy. 
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W tym miejscu musimy stworzyć unikalny plik domeny (ZOB. 
ZADANIE 48). Domena powinna zawierać dwie klasy: start i stop: 

> Domain > Create domain > Domain name (autostrada) > Type > 
Class (zaznaczony) > OK > Edit > Add item… > Name (start) > 
Code (1) > OK > Edit > Add item… > Name (stop) > Code (2) > OK 
> File > Exit 

 

> OK > zaznaczamy warstwę „start” > Edit > Insert mode > 
wstawiamy punkt początkowy > (start) > File > Save > File > 
Exit editor 

 

Powstała mapa z punktem początkowym. Analogicznie tworzymy mapę 
z punktem końcowym: 

> File > Create > Point map > Map name (stop) > Domain 
(autostrada) > OK > zaznaczamy warstwę “stop” > Edit > Insert 
mode > wstawiamy punkt końcowy > (stop) > File > Save > File > 
Exit editor 

Aby powstałe mapy mogły być wykorzystane przy obliczaniu odległości, 
naleŜy zmienić ich format z wektorowego na rastrowy. Chcemy, by plik 
georeferencji był identyczny jak w mapie uŜytkowania terenu CORINE 
2000: 

> przeglądarka plików >> (szczecin_cor) > OK > Boundaries only 
(zaznaczony) > OK 
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> File > Create > Coordinate system > Coordinate system name 
(autostrada) > Coord system formula (zaznaczony) > Related 
coordsys (unknown) > OK > Yes > OK 

 

Współrzędne powinny zostać automatycznie przypisane na podstawie 
pliku CORINE. Dokonujemy konwersji map na format rastrowy: 

> Operation-tree > Rasterize > Point to raster > Point map 
(start) > Point size (1) > Output raster map (start_ras) > 
Georeference > Create georeference > Georeference name 
(autostrada) > OK > Show > OK 

> Operation-tree > Rasterize > Point to raster > Point map 
(stop) > Point size (1) > Output raster map (stop_ras) > 
Georeference > Create georeference > Georeference name 
(autostrada) > OK > Show > OK 

 

Na podstawie punktów powstały dwie mapy rastrowe. Następnym 
etapem jest stworzenie mapy tarcia. W tym celu reklasyfikujemy mapę 
uŜytkowania terenu CORINE 2000, przypisując klasom terenu 
odpowiednie współczynniki tarcia.  

Tworzymy nową tabelę, w której zestawimy numery ID klasy obszaru 
oraz przyznane przez nas (subiektywnie) wartości współczynnika: 

> Operation-tree > Create > New table > Table name 
(tarcie_tab) > Domain (none) > Records (44) > OK 

� W zadaniu 
reklasyfikowane są 
wszystkie klasy 
występujące w bazie 
CORINE 2000. Jednak 
w praktyce na terenie 
Polski nie wszystkie z 
nich występują. 
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> Columns > Add column… > Column name (CODE_00) > Domain 
(value) > Value range (-999), (999) > Precision (1) > OK 

> Columns > Add column… > Column name (tarcie) > Domain 
(value) > Value range (-999), (999) > Precision (1) > OK 

Przypisujemy obszarom kod rodzaju uŜytkowania terenu, który jest 
określony w tabeli: 

> Operation-tree > Vector operations > Polygons > Attribute 
map of polygon map > Polygon map (szczecin_cor) > Table 
(szczecin_cor) > Attribute (code_00) > Output polygon map 
(szczecin_class) > Show > OK 

Zamieniamy wektorową mapę uŜytkowania terenu na mapę rastrową: 

> Operation-tree > Rasterize > Polygon to raster > Polygon map 
(szczecin_class) > Output raster map (szczecin_ras) > 
Georeference > Create > Georeference name (szczecin_cor) > 
Coordinate system (autostrada) > OK > Show > OK 

Dokonujemy reklasyfikacji w oparciu o tabelę z kodami obszaru. 
Wydzielamy pięć klas. Najbardziej korzystne będą łąki i pastwiska oraz 
uprawy jednoroczne (tarcie 1), grunty orne (tarcie 2). Średnio korzystne będą 
sady (tarcie 3). Najmniej korzystne będą lasy (tarcie 4). Przez obszary 
zabudowane, tereny przemysłowe i wody autostrada nie moŜe przebiegać 
(tarcie -1). 

Wpisujemy w wiersz poleceń kolejno: 

reclass1 = IFF ((szczecin_ras = 231), 1, 0) > OK 

 

reclass2 = IFF ((szczecin_ras = 211) OR (szczecin_ras = 212) 
OR (szczecin_ras = 213), 2, 0) > OK 

reclass3 = IFF ((szczecin_ras = 221) OR (szczecin_ras = 222) 
OR (szczecin_ras = 223), 3, 0) > OK 

reclass4 = IFF ((szczecin_ras = 311) OR (szczecin_ras = 312) 
OR (szczecin_ras = 313), 4, 0) > OK 

Dodajemy mapy cząstkowe do siebie: 

reclass_sum = reclass1 + reclass2 + reclass3 + reclass4 

� Najwygodniej 
dokonać zestawienia w 
pliku arkusza 
kalkulacyjnego, a do 
tabeli w programie 
ILWIS wkleić 
przygotowane 
wartości. Aby wkleić 
wszystkie wiersze, 
naleŜy zaznaczyć 
wartości w Excelu, 
skopiować je, a 
następnie zaznaczyć 
nagłówek kolumny w 
ILWISie i wkleić dane. 

� Wszystkie mapy 
cząstkowe powinny 
być wykonane w 
domenie VALUE. 
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Dla pozostałych obszarów, w tym nieoznaczonych, przypisujemy wartość 
ujemną: 

reclass_sum1 = IFF ((reclass_sum > 4), reclass_sum, -1) > OK 

reclass = IFNOTUNDEF(reclass_sum1, reclass_sum1, -1) > OK 

Utworzyliśmy mapę tarcia. MoŜemy teraz w oparciu o nią wygenerować 
mapy odległości od punktu początkowego i od punktu końcowego: 

> Operation-tree > Raster operations > Distance calculation > 
Source map (start_ras) > Weight map (zaznaczony) > mapa 
(reclass) > Output raster map (start_tarcie) > Domain 
(distance) > Precision (0.001) > Show 

> Operation-tree > Raster operations > Distance calculation > 
Source map (stop_ras) > Weight map (zaznaczony) > mapa 
(reclass) > Output raster map (stop_tarcie) > Domain 
(distance) > Precision (0.001) > Show 
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Na mapie odległości wartość piksela określa odległość tego punktu od 
obszaru istniejącego (o wartości większej niŜ 0). Jest to mapa 
przypominająca mapę buforów (ZOB. ZADANIE 40), na której kaŜdy 
piksel przyjmuje wartość ekwidystanty przebiegającej przez niego. PoniewaŜ 
uwzględniamy mapę tarcia, ekwidystanta ma charakter waŜony. 

Powstały dwie mapy, uwzględniające wskaźnik tarcia. Na pierwszej z nich 
(start_tarcie) wartość punktu końcowego „stop” jest największą wartością na 
najkrótszej drodze z punktu „start” do punktu „stop”. Analogicznie na 
drugiej mapie (stop_tarcie) wartość punktu początkowego „start” jest 
największą wartością na najkrótszej drodze z punktu „stop” do punktu 
„start”. JeŜeli chcemy wytyczyć najkrótszą trasę, naleŜy dodać obie mapy do 
siebie. Piksele o najmniejszej wartości pokaŜą najkrótszą trasę. Zakładamy, 
Ŝe błąd moŜe wynieść 1% (1/100): 

mapa_drogi = start_tarcie + stop_tarcie > OK 

mapa_drogi_najlepsza = IFF (mapa_drogi < (MAPMIN(mapa_drogi) + 
MAPMIN(mapa_drogi)*1/100), 1, 0) > OK 

JeŜeli chcemy zamienić końcową mapę na postać wektorową, musimy 
stworzyć mapę, na której korytarz ma wartość „True”, a pozostały obszar 
jest niezdefiniowany: 

najlepsza_export = IFF (mapa_drogi_najlepsza = True, True, ?) 
> Show > OK 

> Operation-tree > Vectorize > Raster to segment > Raster map 
(najlepsza_export) > Connect (8) > Output segment map 
(najlepsza_vec) > OK 

 

 
 


